Under The Microscope

Nicecast Pounces on Snow Leopard

Nicecast IconToday we’ve released an update to Nicecast, in the form of version 1.9.8, which brings with it full Mac OS X 10.6 (Snow Leopard) compatibility. This update features a new version of Instant Hijack for grabbing audio from already-running applications. You should be prompted to update Instant Hijack if you have it installed, but you can also install it by choosing Install Extras… from the Nicecast menu.

It’s also worth noting is that Nicecast now requires Mac OS X 10.5 or higher. It’s been our general policy to support the current OS as well as the previous OS, and with the release of Snow Leopard, that means we’ll be support Mac OS X 10.6 and Mac OS X 10.5. So if you’re still on Mac OS X 10.4, be sure to stick with Nicecast 1.9.7 until you update your OS.

This is, of course, a free update for all licensed owners of Nicecast, so everyone (on Mac OS X 10.5 or higher) is encouraged to update. Just choose Check For Update from the Nicecast menu, or click to download from our site. If you haven’t used Nicecast before, check out the easiest way to broadcast audio from your Mac, with a free trial.

And fear not, Airfoil and Audio Hijack Pro users – updates for both these applications are coming very, very soon as well.

7 Responses to “Nicecast Pounces on Snow Leopard”

  1. Sansadoom says:

    Track Titles Source and Current Track dont work !


  2. Paul Kafasis says:

    Sansadoom: We’re going to need a bit more detail on the problem you’re having, as they show up just fine here. Please contact us directly for support, and we’ll see what we can find.


  3. pbo says:

    Where can we download version 1.9.7 for 10.4 systems?
    Not every one needs 10.5 or is able to upgrade to 10.6


  4. smilespray says:

    I ditto the 1.9.7 request — the broadcast Mac I use runs 10.4


  5. dlmtechnology says:

    thank you for the update, while I don’t use nicecast anymore the updated Instant HiJack was great to get my copy of Airfoil back up to speed, I was getting a little errked at having to relaunch iTunes or Pulsar!


  6. Paul Kafasis says:

    pbo, smilespray: You can get version 1.9.7 from our Legacy page.


  7. Claudio says:

    are you going to do a nicecast for ipod/iphone or what????

    please I need it!!!!!!!!!!!!!!!!


Comments for this post have been closed. Thanks for reading!


Our Software